What browser are you using to access the Continuing Competence Program portal?

September 9, 2015

Are you experiencing any technical issues with the Continuing Competence Program (CCP) portal? It may be because the browser or version of the browser you are using is not compatible with the CCP portal. It has come to our attention a number of pharmacists are accessing the portal through a shared work computer that uses Internet Explorer 8.

Unfortunately, this version of Explorer has become obsolete and may result in technical difficulties, especially when completing the prescribed activity.

To avoid any technical issues, we recommend that you use a different browser (e.g., Firefox or Google Chrome) or download a later version of Internet Explorer. 


← Previous ArticleNext Article →